Mar 192014
 

The Firefox extension for DYMO SDK has been updated to support Firefox 28. The extension is available here. The FAQ article is here.

Please note that the Firefox extension is deprecated. No new development will be done for the extension. For new projects please use the Javascript library from the DYMO Label Framework. We encourage developers to switch to the new API even for current projects. Here are some benefits the new DYMO Label Framework API provides in comparison to the extension:

  • DYMO Label Framework API provides a cross-browser and cross-platform pure Javascript API. The same API supports all major browsers on Windows and Mac. The Firefox extension API can be used only in Firefox on Windows.
  • All necessary Framework installation is done by the DYMO Label software installer. By contrast the Firefox extension must be downloaded by customers separately and installed manually.
  • DYMO Label Framework supports and will support all the DYMO printers. New printers will not be supported by the extension.

The auto-update functionality isn’t included in this version. We will add it later.

 Posted by at 15:08  Tagged with:

  4 Responses to “DYMO SDK Extension Update for Firefox 28.0”

  1. As stated in a previous section concerning Chrome plugin issues, when I installed the DLS (latest version forWindows) on a machine running Windows 8, the framework plugin was not installed. Chrome preferences are set as suggested, but the JAvascript console alerts that label framework plugin is missing (so does the check environment page). I need to print to a labelwriter 450 turbo from a web application but so far I could not find a way. The printer works fine from DLS.
    Please help

  2. It’s saying file it’s corrupt

    • Hi Ryan,

      Can you provide more details regarding this corruption so that I can help you troubleshoot?

      Thanks,
      Jeff

      • After following the link for the extension above, Firefox reports: The add-on downloaded from this site could not be installed because it appears to be corrupt.

        No other information or options are provided.

 Leave a Reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(required)

(required)