Jul 282011
 

We are proud to announce the release of DYMO Label software version 8.3.1 for Mac. This release adds support for Mac OS X 10.7 (Lion). This release is mandatory, earlier releases will NOT work on 10.7. The release is available from here.

Here is some technical information describing the underlying changes in DLS and the printer drivers:

  1. In 10.7 Apple discontinued the Tioga printer driver architecture which had been in use since the initial release of Mac OS X 10.0. The only driver architecture supported in 10.7 is CUPS. DLS prior to 8.3.1. includes Tioga drivers, while DLS 8.3.1 includes both Tioga (for Mac OS X 10.5 and 10.6) and CUPS (for 10.7) drivers.
  2. Apple discontinued WebKit-style Safari plugins. This does not affect DLS itself, but does affect DYMO SDK users. There are two scenarios where SDK users are affected:
    • If a SDK web application uses DYMO Safari plugin directly. In this case the only solution is to switch to DYMO Label Framework JavaScript library. This should be done NOT by DYMO but by the application developer.
    • If a SDK web application uses DYMO Label Framework JavaScript library. In this case the application developer should update their app to use the just released version 1.2  of the library.

So, if you are a developer integrating DYMO printers on Mac platform, here are the steps to make sure your application works on 10.7:

  • tell users to update to DLS 8.3.1
  • if your application is a web application:
    • switch code from using DYMO Safari plugin to using DYMO Label Framework JavaScript Library
    • make sure to use the latest version of the library available (1.2)

Update:

If you are experiencing problems with installing or using the printer try these steps:

  • Unplug printer’s USB cable
  • (Re)Install DLS 8.3.1
  • Reboot Mac
  • Replug printer’s USB cable

If the problem persists, please contact DYMO Tech Support, http://sites.dymo.com/Support/Pages/ContactForm.aspx.

Update Regarding LabelWriter 3xx Series Printers on Mac OS 10.7

DYMO LabelWriter 3xx series printers are not supported on Mac OS X 10.7.  We dropped support for technical reasons – starting with 10.7 the Tioga driver system that DYMO drivers have always used is no longer supported by Apple. So we switched to CUPS drivers, and these do not work with the older 300 series hardware.

Please contact DYMO customer service for assistance – 1-877-724-8324. Sorry for the inconvenience.

 

Jul 272011
 

A new version of DYMO Label Framework JavaScript library is available. This version adds support for Mac OS X 10.7 (Lion).

The js script file is available from http://labelwriter.com/software/dls/sdk/js/DYMO.Label.Framework.1.2.0.js.

The http://labelwriter.com/software/dls/sdk/js/DYMO.Label.Framework.latest.js has been updated to version 1.2.0 as well.

All major browsers are supported: Safari 4-5.1, Firefox 3-5, Chrome, Opera 10. Opera 11 is not supported at the time of writing.

Jul 232011
 

Mac OS X 10.7 (Lion) does not support WebKit style plug-ins. For more details see: http://developer.apple.com/library/mac/documentation/MacOSX/Conceptual/OSX_Technology_Overview/OSX_Technology_Overview.pdf

Beginning in Mac OS X v10.7, Safari does not support WebKit plug-ins because they are not compatible
with the new process architecture. WebKit plug-ins are deprecated.

This change affects DYMO SDK for Mac in the following ways:

  1. DYMO Safari Plug-in will not work on Lion and later. If you use it in your application we recommend to switch to DYMO Label Framework JavaScript Library.
  2. Unfortunately, right now DYMO Label Framework JavaScript Library uses the DYMO Safari Plug-in as well, so it won’t work with Safari on 10.7 either. The current workaround is to use Firefox, or Chrome, or Opera instead of Safari. We are working to update the JavaScript library to be compatible with Safari.
Note that the DYMO AppleScript API does work on Lion.